Apache OpenOffice

提供: ArchWiki
移動先: 案内検索
ノート: OpenOffice.org の公式サポートはドロップされ、"Document Foundation" によるプロジェクトのフォークで、様々な機能の改善や追加がされている LibreOffice が代わりにサポートされています。Dropping Oracle OpenOffice (arch-general) を見て下さい。

Why Apache OpenOffice より:

Apache OpenOffice はワードプロセッサ、スプレッドシート、プレゼンテーション、グラフィック、データベースなどの優れたオープンソースオフィススイートソフトウェアです。多数の言語で使うことができ一般的なコンピュータのほとんどで動作します。全てのデータを国際的なオープン標準のフォーマットに保存するため他のオフィスソフトウェアパッケージからファイルを読み書きすることもできます。どんな使用目的であれ完全に無料でダウンロード・利用することが可能です。

インストール

Apache OpenOffice は AUR からインストールすることができます: openofficeAUR

Java ランタイム環境のインストールが推奨されています。次を参照: Java

Microsoft フォント

ページネーションの問題を解決するには Microsoft の公式フォントが必要です。MS フォントの wiki ページを見て下さい。

拡張の管理とスペルチェック

現在 Arch のパッケージには複数の辞書が付属しています。OpenOffice プログラム (例えば Writer) をロードしてツールメニューから Extension Manager を開いて、あなたの使用している言語が存在するか確認してください。以下の場所を入力することでスペルチェック辞書をインストールできます:

/usr/lib/openoffice/share/extension/install/
ノート: LibreOffice をインストールしている場合、パスは /usr/lib/libreoffice/share/extensions/ に変わっています。

他にもインストールする方法はいくつか存在します:

  • OpenOffice メニューの Extension manager を使ってダウンロード・インストールする - ユーザーの ~/.openoffice.org/3/user/uno_packages/cache にインストールされます
  • 拡張をダウンロードして /usr/lib/openoffice/program/unopkg add extension を使ってユーザーにインストール
  • 拡張をダウンロードして /usr/lib/openoffice/program/unopkg add --shared extension を使ってシステムの全てのユーザーが使えるようにインストール (root 権限が必要)

スペルチェッカー

スペルチェックを使うには hunspell と hunspell の辞書 (hunspell-enhunspell-de など) が必要です。ハイフネーションルールを使うには hyphen (hyphen-en, hyphen-de など) が必要です。類語辞典を使うには、libmythes が必要です。

デフォルトでインストールされている他の拡張

  • pdfimport.oxt - Draw や Impress で PDF ファイルがインポートできます
  • presenter-screen.oxt - ディスプレイを2つ使っている場合にスライドショーのコントロールを増やします
  • sun-presentation-minimizer.oxt - プレゼンテーションのファイルサイズを減らします
  • wiki-publisher.oxt - MediaWiki のマークアップ言語の構文を知らなくても MediaWiki サーバーに Wiki 記事を作れるようになります

マクロのインストール

ほとんどの Linux ディストロでは、マクロのデフォルトパスは:

~/.openoffice.org/3/user/Scripts/

Arch Linux おけるこのディレクトリのパスは:

~/.config/.openoffice.org/3/user/Scripts/

Macros are not guaranted to work in both OpenOffice and LibreOffice, but it is possible to choose a common directory for them. Choose the path in Tools > Options > LibreOffice/OpenOffice > Paths The default path for LibreOffice macros in Arch Linux is:

~/.config/libreoffice/4/user/Scripts/
ノート: マクロを使用する場合、Java ランタイム環境が必須になります。この挙動はデフォルトですが、Java を無効化することでロード時間が高速化されます。

TrueType フォントのインストール

OpenOffice にフォントを追加するには、spadmin を実行してください。

テーマ

OpenOffice supports to use several toolkits for drawing and integrates into different desktop environments in a clean way. To choose by hand, you need to set the OOO_FORCE_DESKTOP environment variable. Its possible values are gnome and kde4.

To configure the look for anytime OpenOffice gets started, you can export the OOO_FORCE_DESKTOP variable in /etc/profile.d/openoffice.sh, or in /usr/bin/soffice. Alternatively you can put the variable in any OpenOffice desktop file in Exec line between Exec and the command, then copy them to $XDG_DATA_HOME/applications in order to prevent overwriting on update.

KDE4/Qt4 ルックアンドフィール

OpenOffice 以外のアプリケーションにも共通する、一般的な方法は Qt と GTK アプリケーションの外観の統合に載っています。

一般的なテーマで別の設定を使う

Xorg サーバーの解像度は KDM で設定することができます。

Do not select Use my KDE style in GTK applications. Instead choose a native syle and font for GTK+ 2 applications.

Use a program like gtk-chtheme to select a style (in general different from KDE) and a font (may be the same as your KDE general system font). There are also other GTK+ engine packages available.

There are two relevant parts of the OpenOffice options dialog, View and Fonts:

  • View
    • Set scale to 100%
    • Set use system font OFF (otherwise replacement table will not be used)
    • Set antialiasing OFF
  • Fonts
    • Select Use replacement table
    • Replace Andale Sans UI (you must type this in -- it is not in the drop down list) with another font (your KDE system font or another if this looks bad)
    • Press the tick symbol to update the list
    • Select Always and Screen only
    • Press OK

When choosing fonts for OpenOffice note that the poor font rendering engine included in the package may not render a particular font in the same way as other apps on the desktop.

OpenOffice の高速化

設定によって OpenOffice の起動時間やレスポンスを改善することができます。ただし、いくつかの設定は多くの RAM を使用することになるので、気をつけて使って下さい。 全て Tools > Options からアクセスできます。

  • メモリ:
    • Undo > Number of steps の数を 100 以下に減らします、40 か 50 ステップくらい。
    • グラフィックキャッシュの、「OpenOffice用に使用」を 128 MB (デフォルト値は 20MB) に設定します。
    • オブジェクト当たりのメモリを 20MB (デフォルト値は 5MB) に設定します。
    • OpenOffice を頻繁に使う場合、クイック起動を有効にします。
  • Java の「Java 実行環境(JRE)を使用」のチェックを外します。
ノート: Java に依存している機能のリストは次のページで見れます: http://wiki.services.openoffice.org/wiki/Java

トラブルシューティング

フォントの置き換え

These settings can be changed in the OpenOffice options. From the drop-down menu, select Tools > Options > OpenOffice > Fonts. Check the box that says Apply Replacement Table. Type Andale Sans UI in the font box and choose your desired font for the Replace with option. When done, click the checkmark. Then choose the Always and Screen only options in the box below. Click OK. You will then need to go to Tools > Options > OpenOffice > View, and uncheck Use system font for user interface. If you use a non-antialised font, such as Arial, you will also need to uncheck Screen font antialiasing before menu fonts render correctly.

アンチエイリアス

次を実行:

$ echo "Xft.lcdfilter: lcddefault" | xrdb -merge

設定を永続化させるには、~/.Xresources ファイルに Xft.lcdfilter: lcddefault を追加してください [1]

上記でアンチエイリアスが有効にならない場合、Xorg が起動されるたびに $ xrdb -merge ~/.Xresources が実行されるようにしてください。ファイルが存在しない場合、作成して下さい。

スペルチェックの問題

OpenOffice 3.0.0-2 現在、文字列のエンコーディングの問題のため辞書が上手く使えないことがあります。問題を修正するには、以下の手順に従って下さい。

Find where the particular openoffice distribution places its dictionary files; e.g., pacman -Ql openoffice-base. Most distibutions follow the convention of installing these to /usr/lib/openoffice/share/extension/install. Once the directory has been found, assign it to a shell variable:

droot="/usr/lib/openoffice/share/extension/install"

辞書ファイルを展開・圧縮できるように unzipzip パッケージをインストールしてください。

For reference, get a list of languages whose dictionary files are packaged with the base distribution:

cd "$droot" && ls | sed -rn 's,^dict-(..)\.oxt$,\1,p'

Define a list of languages whose dictionary files are to be fixed:

lang="en es"

Extract the target languages' dictionary files and convert the erroneous encoding to UTF-8:

tmp="/tmp/dictfix-$USER-$$"

mkdir "$tmp"
cd "$tmp"

for i in $lang; do
    i="$droot/dict-$i.oxt"
    unzip "$i" -d oxt.tmp
    iconv -f ISO-8859-15 -t UTF-8 oxt.tmp/dictionaries.xcu > dict.tmp
    mv dict.tmp oxt.tmp/dictionaries.xcu
    (cd oxt.tmp && zip -r "$i" .)
done

rm -rf "$tmp"

Finally, use the OpenOffice extension manager (available through the Tools menu) to install the dictionary from the resulting dict-xx.oxt file(s).

暗い GTK+ テーマ, アイコン, GTK-Qt エンジン

古いバージョンの OpenOffice/LibreOffice では暗い GTK+ テーマを使っている場合に High Contrast Mode で起動します。このモードでは High Contrast Icons や Calc のセルの背景色を変更することができなくなります。

旧バージョンの OpenOffice (< 3.2.x)

新しいバージョンの OpenOffice / LibreOffice

In newer version of OpenOffice / LibreOffice ( > 3.2.x), the fixes mentioned above do not seem to work. Possible solutions may be:

  • You could manually configure UI colors via Tools > Options > Appearance, yet Impress and Calc may stay dark.
  • Another solution is to disable Automatically detect high-contrast mode of operation system in LibreOffice > Accessibility (> LO 4.1.x).

Now the colors can be configured in Options > Appearance and the selection of another iconset is possible again.

NFSv3 共有を使用するとフリーズする

If OpenOffice hangs when trying to open/save a document located on a NFSv3 share, try prepending the following lines with a # in /usr/lib/openoffice/program/soffice.:

SAL_ENABLE_FILE_LOCKING=1
export SAL_ENABLE_FILE_LOCKING

If you wish to avoid /usr/lib/openoffice/program/soffice overwriting on update just copy it in /usr/local/bin. Original post here.

Java フレームワークエラーの修正

OpenOffice の実行時に以下のようなエラーが表示される場合:

[Java framework] Error in function createSettingsDocument (elements.cxx).
javaldx failed!

以下のようにして ~/.config/ の所有者を変更してください:

# chown -vR username:users ~/.config

詳しくは Arch Linux フォーラムの 投稿 を参照。

OpenOffice が証明書を検出してくれない

If you cannot see the certificates when trying to sign a document, you will need to have the certificates configured in Firefox (or Thunderbird). If after that OpenOffice still does not show them, set the MOZILLA_CERTIFICATE_FOLDER environment variable pointing to your Firefox (or Thunderbird) folder.

export MOZILLA_CERTIFICATE_FOLDER=$HOME/.mozilla/firefox/XXXXXX.default/

See more about certificate detection.